Custom Door Leaf Naming

A few projects have suffered from what seems like a glitch in Cadimage Doors; where the custom settings disappear when you select a custom door leaf, or even select the door leaf tab.

If your door settings look like this, I have a solution for you:

Screen Shot 2016-06-17 at 9.01.56 AM

Door Settings are Missing!

The problem is the naming of the custom door leaf. This door leaf does not need to be applied to the door to cause the glitch. Any component accessible from the elements settings can cause this “glitch”. That is any custom door leaf, window sash, or hardware component. It is caused by the use of special characters in the object/component naming. Special characters should be avoided in all aspects of ARCHICAD, that includes external images, external drawings, attributes, views, etc. A special character is anything except Alphanumeric Characters and the dash or underscore. “,.+#%%@’;:/\?<>!* are all prohibited in library manager content.

By looking at the library manager, I can quickly find the offending component and delete it or rename it:

Screen Shot 2016-06-17 at 9.02.21 AM

25% door 12″ Wide is not an appropriate name for several reasons

Now when I refresh the libraries and go back to my door settings, I can access all door settings:

Screen Shot 2016-06-17 at 9.02.48 AM

Problem Solved!!!!!!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s